Regulatory Information

The **Mimics Innovation Suite** version 23.0 currently consists of the following software components: Materialise Mimics version 23.0 and Materialise 3-matic version 15.0 (version released in 2020). Materialise Mimics and Materialise 3-matic are not medical devices.

**Important note as a reminder:** Any reference that is made to the design of medical devices within the Materialise Mimics 23.0 or Materialise 3-matic 15.0 Reference guide or tutorial refers to a research context. As explained above, Materialise Mimics and Materialise 3-matic are not medical devices.
Contents

Regulatory Information ............................................................................................................. 1
Contents ..................................................................................................................................... 3
1. What’s New ............................................................................................................................... 4
  1.1. General ............................................................................................................................... 4
  1.2. Installation ......................................................................................................................... 4
  1.3. Design ................................................................................................................................ 4
  1.4. SSM .................................................................................................................................... 9
  1.5. Lattice ............................................................................................................................... 11
  1.6. UV Map ............................................................................................................................. 15
  1.7. Texturing ........................................................................................................................... 16
  1.8. Usability improvements ...................................................................................................... 19
  1.9. Scripting ............................................................................................................................ 22
  1.10. CAD Link ......................................................................................................................... 25
  1.11. Minor changes ................................................................................................................. 26
2. Known issues ........................................................................................................................... 29
  2.1. General ............................................................................................................................. 29
  2.2. Import/Export .................................................................................................................... 29
  2.3. View ................................................................................................................................... 29
  2.4. Align ................................................................................................................................... 29
  2.5. Measure ............................................................................................................................. 29
  2.6. Curve ................................................................................................................................... 29
  2.7. Design ................................................................................................................................ 30
  2.8. Finish .................................................................................................................................. 30
  2.9. UV Map ............................................................................................................................. 30
  2.10. Texturing .......................................................................................................................... 30
  2.11. Lattice ................................................................................................................................ 30
  2.12. Remesh ............................................................................................................................. 31
  2.13. CAD Link .......................................................................................................................... 31
  2.14. Script .................................................................................................................................. 31
  2.15. Compatibility .................................................................................................................... 31
3 System Requirements .............................................................................................................. 32
  3.1. Minimum requirements ...................................................................................................... 32
  3.2. Recommended requirements .............................................................................................. 32
4 Contact Information ................................................................................................................. 33
1. What’s New

1.1. General

This Release Notes document is intended for customers who were previously using 3-matic software. All the new features, as well as minor changes and known issues of Materialise 3-matic 15.0 version, are described in this document.

1.2. Installation

If you had a BETA release of Materialise 3-matic 15.0 installed before, you need to first uninstall it before installing this external release. Go to Control Panel → Programs and Features, find the BETA release and double-click to uninstall. Only then install the external release to avoid issues with its installation and use.

After installation and license set-up, it is recommended to first choose Options → Reset User Interface to visualize the new features that have been added.

1.3. Design

Create connections

Materialise 3-matic 15.0 comes with a new tool allowing you to speed up your workflow by automatically creating multiple connections between several parts. Depending on the needs and the complexity of the input, it is possible to automatically or manually generate the connections. The automatic method provides a one-click solution while the manual method ensures precision and flexibility.

The Create Connections tool allows the optional selection of a target entity. This option is used when all parts should be connected to one and the same entity as e.g. benchtop modeling. When using a hollow model, the created connections will not exceed the model its wall.

Left: The output of Create Connections operation. Connections are created as analytical primitives
Right: Analytical primitives are converted into parts.

When no target entity is used, all parts are interconnected. It is even possible to use a single shell model to generate connections within one and the same part. The next picture shows an example after converting the analytical primitives into parts.
When using the manual method to create connections, a preview of the connections is shown. Additionally, it is possible to interactive modify a connection in the work area by holding the Ctrl (+Shift) button. A grab mouse will appear when hovering over the radius, axis or one of the endpoints. Simply click on the property you want to change and start dragging it to the desired location. When not satisfied with one of the created connections, double click one of the endpoints to remove the connection.

Mesh-based preview for analytical primitives

Materialise 3-matic 15.0 comes with an improved preview for the analytical primitives. The improved preview allows easy validation of intersection with meshes. This 3D preview can be toggles via the property page of each analytical primitive. When interactive editing or creating an analytical primitive, the mesh-based preview always appears.
Create analytical primitives

The creation of analytical primitives is revamped. It is now possible to interactive fine-tune the position and properties of the analytical primitive via its preview before executing the operation. In order to activate this behavior, the Ctrl key should be pressed while creating an analytical primitive. The next methods are interactive modifiable:

Create Line:
- Coordinates
- Length and direction

Create Arc
- 3 Point
- Normal, center and radius

Create Datum Plane
- 3 Point
- Midplane
- Through 2 points perpendicular to plane
- Through 2 points perpendicular to view

Create Analytical Cylinder
- 2 Point
- Axis

Create Analytical Cone
- 2 Point
- Axis

Create Analytical Sphere
- Center and radius

Dependent on the analytical primitive chosen method for creation, several interactive controls are available. When hovering over an interactive point, axis or radius, a grab mouse icon appears to modify this property.

Edit analytical primitive

Another improvement to the analytical primitives is the possibility to interactive edit the primitive after creation. When opening the property page of an analytical primitive, an 'Interactive edit' button is visible. Clicking this button activates an interactive state of the primitive which allows editing in the 3D work area. A separate operation page opens e.g. 'Edit Datum Plane'. Hold the Ctrl (+ Shift) button to start modifying the analytical primitive in the work area and press 'Apply' to execute the changes.

The interactive controls are like the controls described in the previous section.

Point based pattern

The mesh based pattern and the point based pattern have been merged in one tool called Point based pattern, as they served identical purposes. The operation page has been
modified to allow placing of pattern entities either on all existing mesh points or on specific points defined by the user manually. The preview has been simplified to show only bounding boxes of pattern entities. Moreover, the OCS defines the orientation of pattern entities on the part as for all other patterning operations. Depth parameter has been renamed to Height offset that defines the perpendicular distance of the patterns from the selected points. Positive offset results in increased distance relative to the normal of the point while negative offset results in increase relative to the opposite of the normal.

![Pattern entities positioned on the bone in preview mode](image1)

![Point based pattern result after applying the operation](image2)

Fillet
The Fillet operation does now accept multiple entities to speed-up your workflow. Furthermore, the operation is improved to better handle complex contours and the operation page has been simplified.

![Input part](image3)

![Output of Fillet operation on multiple contours](image4)
1.4. SSM

In Materialise 3-matic 15.0, the former ADaM module, which allowed to visualize statistical shape models, was expanded to allow the creation of statistical shape models in 3-matic. This expanded module was renamed to the SSM module. It is now possible to warp meshes and create your own statistical shape models using the new SSM module. The details of the newly added tools of the SSM module are described below.

Note that the previous, lighter ADaM module, is still available under the name SSM viewer.

Registration with Scaling

The Registration with Scaling tool provides a one-click solution to register and scale two entities at the same time. Like the global registration tool, it is possible to add move along entities, e.g. landmark points. These move along entities are moved with the same translation and rotation as the moving entity.
**Warp Part**

NOTE: It is advised to align the source and target before warping. A good initial alignment increases the quality of the warping result and reduces computational time.

The 'Warp Part' operation is introduced to obtain part meshes with point's correspondence.

Orange: Target entity     Blue: Source entity
Result of the warp operation

It is possible to add landmarks to the warping operation. The landmarks from source and target entity are matched based on their names so corresponding landmarks should have corresponding names.

The Warp Part tool comes with a lot of flexibility. The deformation parameters, stopping criteria and accuracy parameters are controllable. Fine-tuning the input value for these parameters makes it possible to find the right balance between a satisfying result and the computation time.
Create SSM

Lastly, Materialise 3-matic 15.0 comes with a tool to create statistical shape models. The input consists of a list of parts with point correspondence. This is obtained by warping a source entity to all the different target entities. Depending on the design needs, it is possible to exclude position variations of the separate input parts by enabling the Procrustes analysis.

The property page of the created SSM allows control over the different modes to visualize shape variations. A simplified example is shown:

1.5. Lattice

Voronoi based lattice

Materialise 3-matic 15.0 comes with the new tool allowing to generate a randomized lattice structure based on the Voronoi diagram. Depending on design needs, it can be generated inside the volume, on/under the surface or as a combination of both. High control over porosity and density can be ensured by defining pore radiuses and thickness for a whole part as well as for local areas.
New rendering for lattice beams

The beam rendering has been improved in Materialise 3-matic 15.0. It can now effectively handle larger number of beams compared to the previous versions of 3-matic, due to effective GPU usage.

Attract graph to mesh with clearance

The operation now has the possibility to attract beams to mesh with the clearance to compensate for assigned thickness and thus avoid having beams penetrating the surface after printing.
Control of unit cell height for UV based conformal lattice

In 3-matic 15.0, the UV Based Conformal Lattice operation has been enhanced with the possibility to preserve the height of the unit cell. Regardless of the deformation caused by UV map stretch the Z height will not be affected.

Stitch graphs

Stitch graphs tool has been redesigned in a way to work on a level of connectivity components (graph clusters) that enabled possibility to stitch nodes in a single graph entity.
The operation page has been simplified as well with ‘Minimum stitching radius’ renamed to ‘Tolerance’ that brings more consistency to the software.

Organic lattice structures
The Convert lattice to mesh operation has been enhanced with the possibility to generate mesh in a smooth and organic way, avoiding sharp edges between neighboring lattice beams. The main parameter, allowing users to control organic effect, is organic factor which, in fact, defines a gap closing distance between beams taking into account their thicknesses. A detail size of generated mesh is defined by accuracy parameter either from a graph property page or from the Convert Lattice to mesh operation page.
1.6. UV Map

Create UV map

The Create UV map operation has been extended with the possibility to define XYZ to U and XYZ to V factors separately. If they are not equal values, the operation will result in a rectangular grid suitable for texturing or patterning purposes using non-square pattern entities/unit cells. Moreover, XYZ to U and XYZ to V factors are now editable properties of the UV map object. It is also possible to change the size of UV map any time upon creation without a need to regenerate the UV map. Once it is done, the size of all the UV Regions belonging to this UV map will be adapted accordingly.

Automatic alignment for mantle surfaces
Align UV tool has been enhanced with the possibility to align mantle surfaces automatically while preserving a full number of tiles. If length U and length V are not specified, the UV Regions become squares in UV and if length U and length V are set as different values, the UV Region gets a rectangular shape in UV space.

UV map created on cylindrical surface without alignment

UV was automatically aligned

1.7. Texturing

3D Texture preview

Materialise 3-matic 15.0 introduces a new feature allowing to preview 3D texture result without applying 3D texture operation. Assign the white and black offset values to the 2D texture object in the property page and click ‘3D preview’ to visualize the 3D preview.

2D texture with fading effect applied towards surface border

Preview of 3D texture with fading effect

3D Texture generation

Materialise 3-matic 15.0 applies a different approach for the 3D Texture operation. It’s now possible to define detail size in pixels which gives a much more accurate and optimal mesh result. The operation page has been significantly simplified and now contains only a sufficient
set of parameters such as white and black offsets and detail size in pixels. The triangle reduction is always applied during the operation and can be adjusted afterwards manually.

Procedural leather texture

Materialise 3-matic 15.0 introduces the new way to generate leather texture based on mathematical description, in this case, based on the Voronoi algorithm. The leather texture generated in a procedural way has no stretched effect caused by surface curvature and always has a nice seamless result thus looks more natural.

Start by selecting a surface on which leather texture should be mapped upon generation and create UV map on it *(the size and the alignment does not matter)*
Primary leather parameters define a size and shape and scale of leather cells

Secondary leather parameters control the generation of secondary cells, which are meant to simulate additional detail within the primary cells, along with the leather spots (more information can be found in 3-matic Manual)

---

Preserve height of the pattern entity for UV based rectangular pattern

The UV Based Rectangular Pattern operation has been improved with the possibility to optionally preserve the height of pattern entity for “with deformation” method. Regardless of the stretching effect caused by UV map, the Z height of pattern entities will be preserved.
1.8. Usability improvements

Search bar

Materialise 3-matic 15.0 comes with the Search bar that allows to find and access all registered 3-matic tools in a quick way. Start typing the desired tool name and all matched options will appear in the dropdown list. Using the mouse or up and down keyboard arrows the desired tool can be selected and launched by clicking or pressing the Enter key.

Orientation indicator

The users can now benefit from the new orientation tool called Orientation indicator with an interactive camera orientation interface. It allows selecting one of the six default views and this view be immediately applied to all parts in the work area to re-orient them accordingly.
Indicate view orientation

The indicate view orientation tool has been introduced to give advanced control over the orientation of the part that cannot be achieved with general orientation tools. The user can pick a point on the surface and define the direction by triangle normal, surface normal, triangle edge or free direction. Once the direction is selected, the camera coordinates will be changed accordingly while the zooming setting won’t be affected.

Mass editing and visualization of properties

The property pages for Parts, Surfaces, Surface lists, Surface sets, Analytical primitives, Graphs, Graph lists, Graph sets, Textures, UV maps, UV regions are optimized and adapted for mass editing and mass visualization purposes. The parameters are grouped in a logical way to allow users visualize common read-only properties of selected items as well as change editable ones.
Incremental save project
Materialise 3-matic 15.0 introduces the new tool allowing to save intermediate project results as separate project files keeping track on versioning. The tool is accessible via File menu-> Incremental Save Project or via shortcut key. The first save of the project must be done as usually via Save Project (As), and then every time whenever the Incremental save tool is used, the current design will be saved in the same folder.

Customizable tabs
It is now possible to create your own customized tabs. In order to activate customization, right-click on the toolbar in 3-matic and select Customize or go to Options → Customize User Interface. Another option is to simply click the grey-colored + tab on the tab menu to start creating your own workflow tab. Drag and drop the desired operations in the new tab to build up your workflow. It is possible to create and rename as many tabs as needed.

Import/Export of 3-matic Profile
Your custom 3-matic profile can now be exported and shared. The tool is accessible via Options → Export 3-matic Profile. It exports custom tabs as well as custom toolbars while retaining toolbar/tabs names and icons.

To import a 3-matic profile use Options → Import 3-matic Profile and select the desired *.zip file. The current interface will be overwritten with the imported 3-matic profile.
1.9. Scripting

Python scripts written for previous versions of Materialise 3-matic (until version 14.0) should be re-validated by the user before being run with Materialise 3-matic 15.0. Small updates can break a script in several ways, e.g.: the API functions returning a list in 3-matic 14 will now be returning a tuple, updates of the default value, etc. When adding extra packages to python, make sure jedi 0.9.0 and RPyC 4.0.2 are used. For other versions, the compatibility is not tested on Materialise 3-matic 15.0.

Scripting library

Materialise 3-matic 15.0 comes with a scripting library. It allows easy access to multiple 3-matic python scripts from the menu or toolbar. Scripts can be added to the toolbar/menu by specifying directories via File → Preferences → Scripting. It is possible to add multiple paths. All scripts present in the specified folders will automatically be registered under the Scripting Library. It is then possible to execute such scripts with a single click. This is the ideal method for users who need to execute a script without needing to see or modify the script. It is advised to reset the menu and toolbar defaults via the Options menu to assure the scripting library is updated.

On top of this, it is now possible to use scripts in a customized tab/toolbar. In order to activate customization, click on the grey-colored + tab in the tab menu. A dialog will pop-up which enables creating new toolbars/tabs and adding operations to create a customized workflow. For more explanation, see section 1.6.6. An example is shown below.
Improvements for interactive scripts

Some workflows cannot be made fully automated because user input is needed for some steps. In order to support these interactive scripts better, several API functions are added to activate a feature via the API. Executing one of these API functions pauses the script and activates the feature. The script will resume once the user clicks ‘Esc’. The following table lists the API functions that were added to activate a feature:

<table>
<thead>
<tr>
<th>Function</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>trimatic.activate_mark_lasso_area</td>
<td>trimatic.activate_mark_wave_brush</td>
</tr>
<tr>
<td>trimatic.activate_mark_shell</td>
<td>trimatic.activate_translate_rotate</td>
</tr>
<tr>
<td>trimatic.activate_mark_smooth_region</td>
<td></td>
</tr>
</tbody>
</table>

Full list of API improvements

The 3-matic Python APIs are extended in these primary areas:

**Texturing module**

The Texturing module is now scriptable. To support the texturing features, the 3matic.UVMap, 3matic.Texture, 3matic.UVRegion data types have been added as well. Many existing API functions are modified to support these new types. The following table lists the API functions that are added to support textures:

<table>
<thead>
<tr>
<th>Function</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>trimatic.uv.create_uv_maps</td>
<td>trimatic.texturing.create_fade_texture</td>
</tr>
<tr>
<td>trimatic.uv.align_uv_automatic</td>
<td>trimatic.texturing.create_uv_based_rectangular_pattern_with_deformation</td>
</tr>
<tr>
<td>trimatic.uv.optimize_uv</td>
<td>trimatic.texturing.create_uv_based_rectangular_pattern_without_deformation</td>
</tr>
<tr>
<td>trimatic.types.UVMap.merge_all_regions</td>
<td>trimatic.finish.create_path_based_pattern</td>
</tr>
<tr>
<td>trimatic.texturing.create_uv_based_texture</td>
<td>trimatic.finish.create_point_based_pattern</td>
</tr>
<tr>
<td>trimatic.texturing.convert_texture_to_mesh</td>
<td></td>
</tr>
</tbody>
</table>

**Lattice module**

<table>
<thead>
<tr>
<th>Function</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>trimatic.lattice.create_uv_based_conformal_lattice</td>
<td>trimatic.lattice.attract_graph_to_mesh</td>
</tr>
<tr>
<td>trimatic.lattice.connect_nodes</td>
<td>trimatic.lattice.create_voronoi_based_lattice</td>
</tr>
<tr>
<td>trimatic.lattice.convert_lattice_to_organic_mesh</td>
<td>trimatic.lattice.convert_lattice_to_regular_mesh</td>
</tr>
</tbody>
</table>

**Design module**
For 3-matic 15, the API has been extended with several design functions. The following table lists the added API functions:

| trimatic.create_part          | trimatic.create_connections_automatic |

**SSM module**

For 3-matic 15, the API has been extended with several functions to create statistical shape models via scripting. The following table lists the added API functions:

| trimatic.create_ssm                  | trimatic.warp_part                |
| trimatic.create_ssm_subregion       | trimatic.registration_with_scaling |

The `trimatic.create_ssm_subregion` API function is only available via scripting. It is not visible in the user interface.

**Analyze module**

For 3-matic 15, the API has been extended with several functions to create an analysis via scripting. The following table lists the added API functions:

| trimatic.create_wall_thickness_analysis | trimatic.create_mean_curvature_analysis |
| trimatic.create_maximum_curvature_analysis | trimatic.create_gaussian_curvature_analysis |
| trimatic.create_minimum_curvature_analysis | trimatic.create_segmentation |

**CAD module**

For 3-matic 15, the API has been extended with CAD Link functionality. The following table lists the added API functions:

| trimatic.cad_link_quad_dominant | trimatic.cad_link_voronoi_based |

Other changes

- It is now possible to create/modify groups via the API. A new group data type has been added and next functions are implemented to allow handling of groups:
  - trimatic.create_group
  - find_group
  - find_groups
  - get_groups

- The default values for the quick label API functions are changed. The font height changed to a size of 4mm and the label height changed to a size of 1mm
  - quick_label(entity, text, point, direction, follow_surface=True, alignment=<TextAlignment.Center: 'Center'>, font='Arial', font_height=4, label_height=1, bold=False, italic=False)
  - quick_label_dxf(entity, filename, point, direction, follow_surface=True, scale=1, label_height=1)
- The API functions for Fillet and Create volume mesh are improved along with the UI changes. The output result differs compared to Materialise 3-matic 14. The \texttt{trimatic.fillet_surface} API function has been removed since the same result can be achieved with \texttt{trimatic.fillet}.

1.10. CAD Link

The CAD Link operation has been improved to handle complex parts better. The new Quad Dominant patching method generates more uniform patches that are better aligned with the part's geometry. The next table shows a few examples:

<table>
<thead>
<tr>
<th>Materialise 3-matic 14.0</th>
<th>Materialise 3-matic 15.0</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Materialise 3-matic 14.0" /></td>
<td><img src="image2" alt="Materialise 3-matic 15.0" /></td>
</tr>
</tbody>
</table>
Additionally, it is now possible to indicate how analytical structures should be handled to enhance easy design modifications in CAD/CAM software.

Analytical surfaces are not patched | Analytical surfaces are patched with a single seam | Analytical surfaces are patched

Note: Compared to previous versions, ‘Automatic Splitting’ option is not present in the UI of CAD Link operation and is always by default ON. To turn off Automatic splitting, use:

- **Patching method:** Voronoi Based
- **Patch Density:** None

1.11. Minor changes

General

- Added the possibility to quickly access renaming functionality in the Object Tree via F2 shortcut key and use Tab to switch and rename the next entity in the list, when rename selection is still activated.
- The main toolbar has been enhanced with the possibility to add and remove tools based on specific user needs.
- The calculator has been removed from the View menu
- The entities in the work area no longer overlap the ruler after applying Unzoom all and Zoom Selection operations.
- Smooth shading options have been removed from preferences. The last used shading mode will always be remembered.
- Shading mode of the part is always defined by the part property upon import. If a part has no shading property defined, the default 3-matic shading mode will be assigned.
- The Screen Coordinate System method is removed from the Measure Distance/Angle/Length operation in the Measure menu.
- The option "Cycle color through parts" is by default disabled in the Preferences. (Options > Preferences > Visualization > Part)
- The Customize Shortcuts and Toolbars operation is renamed to Customize User Interface.
- The Reset Menu and Toolbar Defaults operation is renamed to Reset User Interface. Three consecutive dialogs will pop-up to ask you whether you would like to reset the “Menu” toolbar, the “Standard Tabs” toolbar and the “Main” toolbar. When resetting one of the toolbars, customization will be lost.
- The output results of the Analyze Mesh Quality operation are now stored in the metadata.
- The Macros have been entirely removed from 3-matic 15.0.

Mark

- Next two shortcuts are modified:

<table>
<thead>
<tr>
<th>Shortcuts</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Mark &gt; Expand</td>
<td>=</td>
</tr>
<tr>
<td>Mark &gt; Shrink</td>
<td>-</td>
</tr>
</tbody>
</table>

Design

- The ‘New part name’ parameter has been removed from the operation pages for the following tools:
  - Extrude
  - Revolve
  - Sweep
  - Sweep Loft
  - Boolean Union
  - Boolean Intersection
  - Create Non-Manifold Assembly
  - Quick Label
  - Local Boolean
  - Export Sketch
  - Convert Instance to Part
- The ‘Global Registration’ is updated to accept Marked Triangles as an input entity.
- The Boolean operations, merge and duplicates are now able to retain colors.
- The ‘Quick Label’ operation is updated to assure consistency between different software. From now on, It follows the standardized rules:
  “The declared font-size is the measure of the side of the square containing each letter, so approximately the distance between the highest point of the ascender and the lower point of the descender. No letter will be exactly as tall or as wide as the font size”.
  The default font height changed to a size of 4mm and the default label height changed to a size of 1mm.
Lattice
- Keep original surface parameter of Unit Cell based Lattice tool has been standardized and renamed to ‘Remove original’
- ‘Remove original’ checkbox has been removed from the UV based Conformal Lattice operation.
- Memory estimation has been added to the Convert Lattice to Mesh operation
- Create beam tool has been enhanced with possibility to retain graph thickness.
- Preserve boundary unit cells parameter of the UV based conformal lattice tool has been moved from the Expert to the Standard 3-matic mode

Texturing
- Create UV map operation now accepts multiple surfaces belonging to different parts as input entities. Surface connections can be also optionally preserved upon UV map creation.
- Contour curves spanning across different surfaces for merged UV Regions are currently allowed entities for Align UV operation
- Texturing toolbar/menu no longer contains curve/surface related operations. All of them remain accessible from Curve/Surface toolbar/menu
- Path based pattern, point based pattern and mesh-based pattern are no longer available in the Texturing toolbar/menu, but can be accessible from Finish toolbar/menu
- ‘Remove original’ checkboxes were removed from UV based Rectangular Pattern and 3D Texture operation pages
- The TextureLibrary has been extended with a few more high quality bitmaps.
- User Manual has been updated with the general requirements for the 2D textures
- Preserve boundary entity parameter of the UV based rectangular pattern tool has been moved from the Expert to the Standard 3-matic mode

Remesh
- The Create Volume Mesh operation is updated to be more robust and able to handle more complex geometries.

Scripting
- It is now possible to drag and drop python scripts into 3-matic. They will start running immediately.
2. Known issues

2.1. General
- Visualization of menu icons can be distorted or blurred in certain cases, related to Windows. It is advised to set the Windows display settings like scaling factor and resolution to the settings recommended by Windows.
- Under very specific conditions, there might be an incompatibility between 3-matic and Windows-specific add-ons that cause the file explorer window to malfunction, making it impossible to select files for import. A work-around is to drag and drop files into 3-matic. Do contact our support team in case you face this issue.
- In very specific cases, the Registration Wizard might show a wrong ‘Valid Until’ date for registered modules. This is only a visualization issue, actual license will work and remain valid as intended.
- Upon installation, 3-matic will ask for importing previous preferences, even if there are no preferences from previous installations available. Default preferences will be loaded nevertheless in this case.
- After registering a license for the Lattice module, the corresponding menu/toolbar might not immediately appear. Restarting 3-matic is required in this case.
- For specific monitors if scaling is set to 125% in display settings, the progress bars might be cut off for certain operations.

2.2. Import/Export
- Import *.X3D does not have the "Import as one part" parameter. By default the geometries are always imported as one part.
- Upon importing Fluent files, (sur)face names are not retained but renamed to surface-1, surface-2, ...
- When exporting curves and primitives, the chosen export format is not correct in case the output method 'Save in separate files' is selected. 3-matic will always export a *.txt, even if *.igs or *.xml is chosen.

2.3. View
- When zooming in till the maximum in the Work area, the Orientation box changes its original position

2.4. Align
- When applying the ‘interactive positioning’ operation on a datum plane or sketch, this object might get corrupt if it was already selected prior to activating the operation. As a work around, first activate the ‘interactive positioning’ operation, then select the datum plane or sketch.

2.5. Measure
- “True shortest path” Length measurements can give a different value when saving and reopening a project if the coordinate system of the original parts has been updated after the measurement was already executed.

2.6. Curve
- In specific cases, the ‘Create Spiral Curve’ does not take the user defined center point correctly into account.
- While the preview of the 'Create Isouves' operation is not always correct or even missing, the actual resulting curves after applying are correct.

2.7. Design
- Metadata is not preserved when cutting a part with 'Create new part' ON, using the 'Cut' operation.
- The 'Anatomy Reconstruction' might fail/crash on specific (less realistic) input data.
- When interactive editing a datum plane, the point preview can be incorrect. The preview of the datum plane itself is correct as well as the output after pressing apply.

2.8. Finish
- The result of the 'Smooth Edge' operation can be different from 3-matic 13.0 in certain cases, affecting the resulting surface structure. This does not affect the correctness of the output itself.

2.9. UV Map
- In case conflicting alignment constraints are given when performing the UV alignment operation, this may lead to an invalid UV Map.
- If the UV page is open (and has focus) upon import of files, the resulting parts will be wrongly appearing in the UV page, instead of 3D preview. Exiting the UV page before doing any import is recommended.
- The XYZ to U and XYZ to V factors of a UV Map are not updated if the corresponding part has been rescaled (e.g. via the 'Scale' operation in the Align toolbar/menu)
- When applying 'Optimize UV' with Area mode, the UV map might get corrupted on specific models.

2.10. Texturing
- When applying a square texture on a UV map that has (or had) a non-square texture initially, the aspect ratio of the square texture will be distorted.
- If 'Procedural leather texture' is applied with the option 'round cells' selected, the memory consumption and operation execution time might go up significantly.
- If the input part for 'Procedural leather texture' contains multiple UV maps, the texture will be generated only for the first one from the list.

2.11. Lattice
- Memory estimation for Convert Lattice to Mesh tool can seriously overestimate with extreme parameters for Organic mesh type
- A result of 'Convert Lattice to Mesh' operation with organic effect is not always smooth for graphs with different thicknesses if they have shared nodes.
- For certain interactive operations (e.g. Interactively Translate Graph Edges) the selection filter might get disabled, preventing you from making a graph selection in the 3D view. As a workaround the entity selection box should get focus again in the operation page.
- In very specific cases, picking and rotating a part with graphs in the Work area might result in short time 3-matic freezing.
- The ‘Texture Based Thickness’ operation is intended to be used with UV regions on (almost) flat surfaces only. If a UV region based on a non-flat surface is selected, outcome might be incorrect.

2.12. Remesh
- The ‘Analyze Mesh Quality’ operation is marking only bad volume elements, instead of also marking the corresponding triangles of the surface.
- When applying the Uniform Remesh operation on parts containing invisible surfaces, it will make the invisible surfaces visible again. The output result is not influenced.

2.13. CAD Link
- The CAD Link operation might crash on specific input data. It is recommended to fix parts upfront and to assign realistic parameters.

2.14. Script
- Using the Procrustes analysis upon creating a subregion SSM with trimatic.create_subregion_ssm might result in inverted modes compared to the input SSM. It might help to assure good initial alignment before creating the full SSM (input SSM).

2.15. Compatibility
- 3-matic doesn't support triangle color information when loading *.magics files.
- Parts imported with *.magics file can have different orientations in 3-matic and Magics (Modeler scene)
3 System Requirements

3.1. Minimum requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows® 10 version - 64bit</td>
<td>Third generation Intel® Core™ i3 or equivalent</td>
</tr>
<tr>
<td>Internet Explorer® 11 or equivalent</td>
<td>8 GB RAM</td>
</tr>
<tr>
<td>PDF viewer</td>
<td>DirectX® 11.0 compliant graphics card with 1GB RAM</td>
</tr>
<tr>
<td>.NET framework 4.6.1 (or higher)</td>
<td>15 GB free hard disk space</td>
</tr>
<tr>
<td></td>
<td>Resolution of 1280x1024</td>
</tr>
</tbody>
</table>

Note: Mac® users can install the MIS using Boot Camp® in combination with a supported Windows OS.

3.2. Recommended requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows® 10 version - 64bit</td>
<td>Third generation Intel® Core™ i5/i7 or equivalent</td>
</tr>
<tr>
<td>Internet Explorer® 11 or equivalent</td>
<td>16 GB RAM</td>
</tr>
<tr>
<td>PDF viewer</td>
<td>DirectX® 11.0 compliant AMD Radeon/NVIDIA® GeForce® card with 2GB RAM</td>
</tr>
<tr>
<td>.NET framework 4.6.1 (or higher)</td>
<td>20 GB free hard disk space</td>
</tr>
<tr>
<td></td>
<td>Resolution of 1920x1080 or higher</td>
</tr>
</tbody>
</table>

It is recommended to use our software within a hardware and/or network environment in which cyber security controls have been implemented including anti-virus and use of firewall.

The following operating system versions were used to test Materialise 3-matic 15.0:

- Windows 10 Pro/Enterprise version 1709, 1809, 1903, 1909 64-bit

Materialise 3-matic 15.0 software and does not degrade in performance. Its lifetime is determined by commercial requirements, obsolescence of its techniques or obsolescence caused by changes in its host environment (refer to above requirements). Support can in any case not be guaranteed beyond 24 months after the release of this particular version of the software.
4 Contact Information

For technical support, please contact our Customer Support team: mimics@materialise.be.

For scripting related support, the MIS Scripting Forum can be consulted as well: https://community.materialise.com/