Materialise Mimics Medical

Version 23.0 - Release Notes
Regulatory Information

The medical edition of the Mimics Innovation Suite software version 23.0 (released in 2020) consists of the components Materialise Mimics Medical 23.0 and Materialise 3-matic Medical 15.0.

Materialise Mimics Medical (briefly ‘Mimics Medical’) is intended for use as a software interface and image segmentation system for the transfer of medical imaging information to an output file. Mimics Medical is also intended for measuring and treatment planning. The Mimics Medical output can be used for the fabrication of physical replicas of the output file using traditional or additive manufacturing methods. The physical replica can be used for diagnostic purposes in the field of orthopedic, maxillofacial and cardiovascular applications. Mimics Medical should be used in conjunction with expert clinical judgement.

Materialise 3-matic Medical (briefly ‘3-matic Medical’) is intended for use as software for computer assisted design and manufacturing of medical exo- and endo-prostheses, patient specific medical and dental/orthodontic accessories and dental restorations.

Usage of the software signifies your acceptance of the above. Please refer to the Instructions For Use for more information.

Manufactured in Aug 2020 by
Materialise NV
Technologielaan 15
3001 Leuven, Belgium
Phone: +32 16 39 66 11
www.materialise.com

<table>
<thead>
<tr>
<th>管理医療機器</th>
</tr>
</thead>
<tbody>
<tr>
<td>一般名稱</td>
</tr>
<tr>
<td>販売名</td>
</tr>
<tr>
<td>認証番号</td>
</tr>
<tr>
<td>送料製造</td>
</tr>
<tr>
<td>販売業者</td>
</tr>
<tr>
<td>製造元</td>
</tr>
</tbody>
</table>

L-10656-02
Contents

Regulatory Information .................................................................................................................. 1
Contents ........................................................................................................................................ 3
1. What’s New ............................................................................................................................... 4
  1.1. Metal Artifact Reduction .................................................................................................. 4
  1.2. Image Registration .......................................................................................................... 7
  1.3. Usability improvements ................................................................................................... 11
  1.4. Export to DICOM functionality ....................................................................................... 13
  1.5. PACS integration ............................................................................................................ 14
  1.6. Other improvements ....................................................................................................... 17
2. Known Issues ............................................................................................................................. 20
  2.1 Base module – general .................................................................................................... 20
  2.2 Base module – segmentation .......................................................................................... 21
  2.3 Other modules ................................................................................................................ 21
3. System Requirements ................................................................................................................. 22
  3.1. Minimum Requirements ................................................................................................ 22
  3.2. Recommended Requirements ........................................................................................ 22
4. Contact Information ................................................................................................................... 23
Appendix A – Working with multiple image stacks ................................................................. 24
Appendix B – PACS integration – Advanced notes ................................................................. 27
  A.1. Installation ...................................................................................................................... 27
  A.2. Administration mode ....................................................................................................... 27
This document applies to Materialise Mimics Medical version 23.0.1. If you have Materialise Mimics Medical 23.0 installed, it is recommended to uninstall it perform a fresh installation of Materialise Mimics Medical 23.0.1

1. What’s New

The main highlights of this release are a tool for metal artifact reduction, better support for image registration, PACS integration with extra Export to DICOM functionality, and various usability improvements.

1.1. Metal Artifact Reduction

Metal objects such as implants or devices present in the patient’s body can cause severe scatter effects on the images, leading to a very time-consuming segmentation process. Mimics now includes an image filter to reduce such effects. This can help to speed-up the segmentation process.

Example (original images with scatter on the left, filtered images on the right):

![Original Images with Scatter](image1.png) ![Filtered Images](image2.png)

It is advised to always review resulting segmentations on the original images. To facilitate this, Mimics allows the user to show the original and filtered images side-by-side and to overlay the segmentations created on the filtered images on the original images.

1.1.1 The “Reduce Scatter” tool

The image filter is available in the “Reduce Scatter” tool, under the ‘Image’ menu.

![Image Filter Menu](image3.png)

As inputs, the tool requires the image stack that needs to be filtered (this should be a CT or Cone Beam CT stack) and a mask representing the metal objects in the scan.
The tool has one parameter, the filtering strength. A filtering strength of 100% will give the strongest possible correction, but can result in blurring of the anatomy. A smaller filtering strength might leave some scatter effects but will better preserve the anatomy (i.e., stay closer to the original images). The optimal filtering strength is case-dependent (for CMF cases for instance, lower values of the filtering strength often perform better than very high values).

The tool is applied in two steps:

- **Step 1 – single-slice preview:**
  First, launch the tool and select an image stack and metal mask. The tool will go to preview mode. Mimics switches to a side-by-side layout that shows the selected stack (left) and a preview of the filtered image (right).

  ![Preview](image)

  The purpose of this preview is to allow the user to tune the filtering strength if needed. Note that this preview is only calculated for one image slice of the entire stack (the displayed image slice) and that preview is approximate (so results in the final calculation might still be different).

- **Step 2 – calculation on the entire image stack:**
  After having selected the proper filtering strength, press ‘OK’ to start filtering the entire image stack. This calculation can take a number of minutes, depending on the size of the stack. (Most cases are processed in less than five minutes.) As a result, a new image stack is created with the filtered images. Note that you might have to tune the image contrast of the new image stack via the ‘Contrast’ tab in the Mimics Bottom Panel.

1.1.2. Using Mimics’ multi-stack support for Metal Artifact Reduction

Since version 21.0, Mimics has support for working with multiple image stacks in a single Mimics project. As mentioned above, when applying the “Reduce Scatter” tool, this creates a
new image stack with the filtered images, effectively making your project a ‘multi-stack’ project. Below we briefly describe one possible workflow that you could follow, making use of Mimics’ multi-stack support. If you are not yet familiar with the multi-stack concept, we strongly recommend to read Appendix A first.

- Suppose you start from a Mimics project containing only a single image stack (with scatter). After running the “Reduce Scatter” tool, Mimics will create a second image stack in the project, containing the filtered images. You can check which image stacks you have in your project in the ‘Images’ tab of the Project Management panel. You can recognize the filtered images by the “Reduce Scatter” prefix in the name.

- Next, you can visually compare the filtered images with the original images. To do so, you can activate a multi-stack layout, and show the filtered images and the original images side-by-side (via View > Layouts).

Example of the “2D by 2D” layout, showing the original images (left) and filtered images (right) side-by-side in axial view:

- If the filtered images are of sufficient quality, you might decide to perform the segmentation on the filtered images. To do so, make sure the filtered image stack is the active stack (as indicated by the blue rectangle), and perform the segmentation using your favourite Mimics tools. Note that you could segment while being in a side-by-side layout, so you can continuously visually refer to the original images too. Alternatively, you can return to the single-stack layout showing only the filtered images.
At the end of the segmentation (or even during the segmentation), you can visualize the segmentation created on the filtered images on top of the original images. To do so, make sure you are in a side-by-side layout and turn on Mimics’ overlay function (View > Overlay). In this way, you can review the quality of the segmentation on the original images.

If you created a mask and corresponding 3D Part by working on the filtered images as above, the mask and Part will be linked to the filtered image stack. Via the Project Management panel, you can now re-assign the mask and Part so that they become linked to the original image stack if desired (cf. Appendix A).

1.2. Image Registration

Mimics now has better support for image registration, with a new registration tool and several other extensions. Supported scenarios include CT versus MRI, post-op versus pre-op, and 4D use cases.

1.2.1. Preliminaries: Creating a multi-stack project

For the new features to be enabled in Mimics, you need to have at least two image stacks in the loaded Mimics project (for instance a CT and an MRI stack, or a pre-op and a post-op stack, etc). So the first step is to create such a ‘multi-stack’ project. There are three ways to do so. We illustrate this on the case of CT-MRI registration, but it applies equally well to the other use cases.

- Import all your DICOM files (CT and MRI) at once via File > New Project. Mimics will separate the images upon import and create a project with two image stacks correspondingly.
- If you already have a Mimics project containing for instance the CT stack, you can use File > Add Images to add the MRI images to it (or vice versa). This will create a second image stack in that project.
- If you already have two separate Mimics projects containing respectively the CT and the MRI stack, you can merge them into one project by opening one of the two projects and using File > Import Project to import the other project into it. This will create a second image stack in that project.

1.2.2. New registration tool (Image > Automatic Registration)

The ‘Image’ menu now contains two icons related to image registration:

- ‘Landmark Registration’ is the new name for the old ‘Image Registration’ tool (no changes were made to the tool).
Automatic Registration is a new feature, as explained below. (It will be greyed-out in the menu if you are working with a project having only one image stack.)

The ‘Automatic Registration’ tool allows to register two image stacks. It works as follows:

- First select a fixed image stack and a moving image stack.
- Next, the tool automatically enters in “pre-alignment” mode. In this mode, the moving image appears in transparent overlay on top of the fixed image, and can be moved by dragging the image with the mouse. The idea is to manually do a rough pre-alignment of the two image stacks before calling the automatic registration. (The transparency level can be adapted.)

- Next, as an optional step, a region of interest can be specified via a bounding box or supplying a mask. The automatic registration will then optimize the fit on this region of interest instead of on the entire field of view.
- Finally, run the registration.

Note: This tool supports only rigid image registration

The tool calculates a transformation matrix to align the moving image with the fixed image. However, this transformation matrix is not immediately applied to the moving image (in other words: the moving image will be in the same position as before). Rather, this transformation matrix is stored in a ‘Transformation’ object created in the Project Management panel, and then can be applied to the moving image (see below).

1.2.3. ‘Transformation’ objects in the Project Management panel

A new tab called ‘Transformations’ has been added in the Project Management panel. If you can’t find the tab in the Project Management panel, please make sure it is turned on (go to View > Project Management).
Example of the 'Transformations' tab:

New transformation objects can be added to the project in three possible ways:

- As explained above, running **Image > Automatic Registration** automatically produces a new transformation object. (The transformation will not automatically applied to the moving image yet.)
- As of this release, running **Align > Global Registration** also automatically produces a transformation object, provided that you have checked the checkbox in the tool. (The transformation will immediately be applied to the moving objects.)
By pressing the New button (‘+’ icon) in the Transformation tab of the Project Management panel, you can create a new transformation object from a specified transformation matrix, either by manually entering all the values of the matrix or by loading it from a text file.

Some actions on transformation objects are now available. This includes inverting a transformation or exporting a transformation to a text file (right-click on a transformation object to select the appropriate action).

1.2.4. Applying a transformation on an image

To apply (or unapply) a calculated transformation on an image stack, and thereby move the image stack in 3D space, go to the Images tab of the Project Management panel, right-click on the image stack, select ‘Transformation’, and select the proper transformation object from the list.

When an image stack is in a transformed state (= has any transformation applied to it other than None), a ‘T’ is shown on top of the image thumbnail of the Images tab.

When there are objects linked to the image stack, applying a transformation to the image stack will move not only the image stack but also these linked objects. In other words: the objects move along with the image. This currently applies to the following types of objects only: Masks, Parts, STLs and Analysis Objects (primitives). Similarly, when unapplying a transformation on an image, the objects will move back to their original position (as if applying the inverse transformation).
1.2.5. **Applying a transformation on an object**

Apart from letting objects move along with an image, as explained above, it is also possible to apply a transformation to objects without moving the image. To do so, go to the Objects tab of the Project Management panel, right-click on an object and select “Transform Objects”. The following dialog window will appear.

This currently is supported for the following types of objects only: Parts, STLs and Analysis Objects (primitives).

1.3. **Usability improvements**

Mimics 23.0 includes improvements to the user interface (UI) as well as quicker ways to import images.

1.3.1. **UI improvements**

For the following tools, the dialog window was updated to the new UI style, bringing increased consistency across the UI.

- Segment > Region Grow
- Segment > Calculate Part
- Segment > Edit Masks
- Segment > Boolean Operations
- Segment > Morphology Operations
- Segment > Smart Expand
- 3D Tools > Edit Contours
- 3D Tools > Smooth
- 3D Tools > Reduce
- 3D Tools > Wrap

Example for Segment > Region Grow:
For the following tools, minor cosmetic updates were done to the UI.

- *Segment > Smart Fill*
- *3D Tools > Hollow*
- *Analyze > Fit Centerline*
- *Advanced Segment > Cut Airways*
- *Project Management pane – 3D objects – Part Properties*
- *Project Management panel – Analysis objects – Properties pages*

### 1.3.2. Import of images (New Project)

Two new fast ways for starting a new project (image import) are now available:

- When you already have a Mimics session opened:
  You can **drag-and-drop** a folder with DICOM files from the Windows explorer into the Mimics window. This will trigger the New Project wizard.

- When you do not have a Mimics session opened yet:
  You can **right-click** a folder with DICOM files in the Windows explorer and select “**Open in Mimics**”. This will launch Mimics and trigger the New Project wizard.

Note that both these options also work when applied on a zip archive with DICOM files.

Additionally, Mimics now has a new Command Line Interface for launching image import from the Windows command prompt. See details in the User Guide (chapter on ‘New Project’).
1.4. Export to DICOM functionality

New features are available for exporting screenshots and 3D Parts in the DICOM format. This allows the user to store the data in PACS (see the ‘PACS integration’ section below). Such files can also be opened in regular DICOM viewers.

1.4.1. 3D View screenshots

Two new features are available for exporting screenshots to DICOM format.

- You can export a single screenshot of the 3D view to a DICOM file.
- You can export a series of 360° screenshots to a single DICOM file.

The features are available via File > Export > Images/Masks.

After export, you can check the location of the exported file in the log window in case you cannot find back the file.

1.4.2. 3D Parts (“DICOM Encapsulated STL” & “DICOM Surface Segmentation Object”)

Two new features are available for exporting 3D Parts (STL) to DICOM format. They export in different formats:

- **DICOM Encapsulated STL**: This is following the new standard for 3D printing, ‘Encapsulated 3D Manufacturing Model’, see http://dicom.nema.org/medical/dicom/current/output/chtml/part03/sect_A.85.html.
- **DICOM SSO (Surface Segmentation Object)**: This is an older standard, see http://dicom.nema.org/medical/dicom/current/output/html/part03.html#sect_A.57.

The features are available via File > Export > Parts.
Note that in a multi-stack project, it is possible to export STLs of the active image stack, not of other stacks or STLs not assigned to any stack.

After export, you can check the location of the exported file in the log window in case you cannot find back the file.

DICOM STL files can also be imported via File > Import > DICOM STL. This supports the two above-mentioned formats (Mimics will automatically recognize which format the file is in).

### 1.5. PACS integration

Mimics now has support for PACS integration. This new component allows the user to configure the connection to a PACS server, retrieve images from the PACS for import into Mimics, and send back data in DICOM format to the PACS.

We explain the basic usage below. For some extra information, see Appendix A of this document.

**Note:** This feature is licensed under a separate module ("PACS integration"). More details on how to configure and troubleshoot PACS connections can be found in the PACS Admin Guide (L-101202-01)

#### 1.5.1. File > Configure PACS

The feature File > Configure PACS allows the user or the administrator to configure the connection to the PACS server.

Example when being in user-managed mode:
Note that in case of configuration problems, we recommend to turn on “verbose” logging for a period of time to facilitate troubleshooting. See the “Log” section of File > Preferences.

1.5.2. File > New from PACS

The feature File > New from PACS allows the user to query-and-retrieve images from the PACS system and import them into Mimics.

First, search for the relevant files:

In the ‘Result’ pane, click on the arrow next to a series to expand the series:

Checkboxes are shown for the expanded series. Check one or more series that you want to download:
After downloading is complete, select the series you want to import into Mimics:

Pressing 'Import' will trigger the New Project wizard.

1.5.3. **File > Send to PACS**

Mimics supports sending two types of files to PACS:

- **3D view screenshots** in DICOM format (either a single 3D view screenshot or a series of 360° screenshots),
- **3D Parts (STL)** in DICOM format.

In order to be able to send such files to PACS, you first need to create the files via the **File > Export** menu, as explained earlier in this document. Once you have the exported files on your disk, you can upload them to PACS via **File > Send to PACS**. Inside the dialog window, you can see a preview of the file content of each file to be uploaded.

1.5.4. **File > Review PACS Uploads**

After having used **File > Send to PACS**, you can check the progress of the uploading via **File > Review PACS Uploads**.
1.6. Other improvements

1.6.1 Volume rendering

The visualization of the volume rendering was improved.

1.6.2 MPR (reslice) improvements

Several improvements were made to the MPR feature (View > Reslice > Along Plane). First, the visualization was enhanced. More importantly, the cursor behavior was updated.

The cursor behaviour is relevant while working on an MPR view with a tool that has its own cursor behaviour, like a cursor for marking (Edit Masks, Multiple Slice Edit, Split Mask, ...) or indication (creation of points, splines, …), etc. The main question is how the tool should behave while the cursor is moved on top of the MPR crosshairs: should the cursor keep behaving as the regular “tool cursor” of that tool, or switch to the “MPR cursor” that allows to manipulate the MPR crosshairs. As of Mimics 23, these tools now support two “cursor modes”:

- By default, the “tool cursor” mode is on. In that mode, you can use the tool cursor for marking, for indication, etc, even while your cursor is hovering over the MPR crosshairs.
- You can switch to the “MPR cursor” mode at any time by holding the SHIFT key.

1.6.3. Logger improvements

The following improvements were made:

- Help > Collect Log Files: This is a new feature in the Help menu. It creates a zip file with log files on your desktop. This is an easy way to collect log files in case of support questions.
- File > Preferences: In the ‘Log’ section of Preferences, a new option for Verbose Logging was added. This can generate more detailed information in case of support questions.
- Log window behavior: Performance was improved (if you scroll up in the log window, the content is loaded on demand instead of always being pre-loaded), and some extra
options were added to the context menu (right-click inside the log window to see the options).

1.6.4. Cut Through Points

The ‘Cut Through Points’ feature was previously located in the ‘Advanced Segment’ menu and available only under the Pulmonary module. The feature is now located in the ‘3D Tools’ menu together with the other cut tools and is now available if you have any of the following modules: Simulation, Design, or Pulmonary. Note that this feature can be useful in the creation of anatomical models for printing.

1.6.5. Other updates

- Small improvements were done to View > Cine Loop and View > Fluoroscopy.
  - In Fluoroscopy mode, Point and Line objects can now be visualized on the Simulation view. To support the new functionality the Python API was updated.
  - Also in Fluoroscopy mode, the Hi/Low resolution option was removed. In Mimics 23.0 the Fluoroscopy is always rendered in high resolution.
  - In the Cine loop, a new behavior was introduced when closing the Cine Loop:
    - Old: when you close the Cine Loop, the last visualised image stack became the active stack
    - New: the image stack that was active before having started Cine Loop will remain active afterwards
- Small cosmetic updates were done to the Project Management panel (fonts, look of the tabs, …).
- Measure > Area: The SHIFT shortcut for drawing spline-shaped segments is changed to SHIFT+CTRL.
- The File > Export menu has been reorganized into submenus.
- Previously, when doing Image > Reslice Images, the DICOM tags were removed. Now they are preserved.
- Minor changes in the results of following features can be observed:
  - Calculate Part:
    - Improved behavior in case first and last slice are selected in the mask.
    - Minor changes give slightly different results in other areas.
  - Centerline measurements
  - Smart Expand
2. Known Issues

2.1 Base module – general

- Mimics main window frame loses focus when switching layout or zooming to full screen. (Issue: 512307)
- Python API: mimics.data.images[].physical_dimensions are returned as (width, number of slices, height) while it is expected to be (number of slices, width, height). (issue: 636577)
- File > preferences > 3-matic: auto search for the 3-matic installation take long. (issue: 673717)
- File > New from PACS: Download fails in case of very long Patient ID (Issue 775237).
- File > new from PACS: import from PACS via C-move protocol will wrongly trigger the non-strict import warning.
- File - Image import: when importing a non-aligned image stack the slice position in the Z-position will have a slight deviation compared to the original Dicom tags. (issue: 744982)
- File > save as: running two instances of Mimics opening the same file may corrupt the file (issue: 792715)
- File > Import STL: If you export an STL to DICOM, upload it on the CONQUEST PACS server, then retrieve it from PACS and try to import this again in Mimics, import will fail. (Issue 767413)
- File > anonymize: the anonymized study ID (0020,0010) exceeds the allowed 16 chars. (issue: 804032)
- File > anonymize: padding symbol 0x00 is used instead of 02/00 for padding of data element values that are character strings. (issue: 804033)
- Memory leak: deleting measurements does not clear the memory fully. (issue: 796626)
- Rendering: New renderer uses more Video RAM.
- View > Cineloop: in rare cases the cineloop doesn’t play. (issue: 698468)
- View > Fluoroscopy: unexpected angles changes for oblique images (issue 815988)
- View > MPR (View > Reslice > Along Plane): As explained in Section 1.6.1, you can activate the MPR cursor mode by holding the SHIFT key. Known issue: after pressing SHIFT you need to move the cursor before it effectively switches to MPR cursor mode. (Issue 759037)
- Win server: concurrent access to the same file is not supported and may yield in error messages or closing of the project. (issue :808573,808579,808580)
- Image > Organize images: seldom crash of organize images on specific CPU setup. (issue: 761161)
- Image > Automatic Registration: Outputs of subsequent results differ (issue: 802365)
- PACS integration and Export to DICOM: The features do not support the use of diacritics in file names or DICOM tags. (Issue 767179, 767215, 767285)
- File – New from PACS: if patient name is too long download from Conquest will fail (issue 814980)
- Once MIS Medical is updated to a newer version, the installation folder will change to default. A simple workaround is to uninstall the previous version of MIS Medical 23.0 and install a fresh copy of newer version of MIS Medical 23.0.1
2.2 Base module – segmentation

- Advanced segmentation – CT heart: price per case licenses will fail if licenses are present locally and on a floating license server. (issue: 702795)
- 3D tools: deleting a mask/part when a tool is active will restore the object after closing the tool. (issue: 710467)
- 3D tools: Created analysis planes or mirror planes when a 3D tool was open, will be lost when closing the tools. Pressing undo will make the planes again available. (issue: 803270)
- 3D tools – cut orthogonal to scene: stop button does not work (issue: 806276)
- Advanced segment – Cut Airway: showing cutting contours preview can be slower compared to Mimics 22.0 (issue: 806635)

2.3 Other modules

- Simulate - Cut - With Polyplane: in rare cases the part is not fully cut. Workaround apply triangle reduction before cutting or fix the cut part in 3-matic. (Issue: 489675).
- Centerline – fit centerline: fit centerline results may differ on different hardware. The result is still within the acceptance criteria. (issue: 794485)
- Scripting: func_view_maximize: restore view dimensions may differ depending on starting zoom level of current view (issue 807299)
# 3. System Requirements

## 3.1. Minimum Requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows® 10 – 64bit</td>
<td>Third generation Intel® core i3 or equivalent</td>
</tr>
<tr>
<td>Internet Explorer® 11 or equivalent</td>
<td>8 GB RAM</td>
</tr>
<tr>
<td>PDF viewer</td>
<td>DirectX® 11.0 compliant graphics card with 1 GB RAM</td>
</tr>
<tr>
<td>.NET framework 4.6.1 (or higher)</td>
<td>15 GB free hard disk space</td>
</tr>
<tr>
<td></td>
<td>Resolution of 1280x1024</td>
</tr>
</tbody>
</table>

Note: Mac® users can install MIS using Boot Camp® in combination with a supported Windows OS

## 3.2. Recommended Requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows® 10 – 64bit</td>
<td>Third generation Intel® Core™ i5/i7 or equivalent</td>
</tr>
<tr>
<td>Internet Explorer® 11</td>
<td>16 GB RAM</td>
</tr>
<tr>
<td>PDF Viewer</td>
<td>DirectX® 11.0 compliant AMD Radeon™ / NVIDIA® GeForce® card with 2 GB RAM</td>
</tr>
<tr>
<td>.NET framework 4.6.1 (or higher)</td>
<td>20 GB free hard disk space</td>
</tr>
<tr>
<td></td>
<td>Resolution of 1920x1080 or higher</td>
</tr>
</tbody>
</table>

Note: Other qualifications may apply. When working with datasets larger than 1GB the system should comply with the recommended system requirements. Advanced segmentation tools such as Smart Expand and Coronary segmentation require hardware as specified in the recommended requirements even for smaller datasets. When working with 4D or multi stack data, the amount of RAM needed increases as you import more image series into the project.

The following operating systems were used to test Mimics 23.0:

- Windows 10 Pro/Enterprise version 1709, 1809 64-bit
- Windows 10 Enterprise, 2015 LTSB 10240
- Windows Server 2019 Standard version 10.0, RDP
4. Contact Information

For technical support, please contact our Customer Support team: mimics@materialise.be.


For scripting related support, the MIS Scripting Forum can be consulted: https://community.materialise.com/.
Appendix A – Working with multiple image stacks

As of version 21.0, Mimics has support for working with multiple image stacks in a single Mimics project. This section is a short recap of the main concepts. We illustrate some of the concepts in the context of metal artifact reduction (cf. Section 1.1), but they apply equally in the context of image registration (cf. Section 1.2).

- The ‘Images’ tab in the Project Management panel:
  You can check which image stacks you have in your project in the ‘Images’ tab of the Project Management panel.

- The concept of ‘active’ image stack:
  When working with a project containing multiple image stacks, at any point exactly one stack is designated as the ‘active’ stack. The active stack can be recognized via the blue triangle. This blue rectangle is visible in the ‘Images’ tab and in the 2D viewports.

- Displaying two image stacks side-by-side:
  In the default Mimics layout, you see only one image stack at a time (the active stack). However Mimics also has so-called ‘multi-stack layouts’ in which you can display multiple stacks side-by-side. Go the ‘View’ menu and select the desired layout.

The following multi-stack layouts are available.
Upon triggering a multi-stack layout, some of the 2D viewports of the layout will be empty. To populate an empty viewport with a particular image stack you can use drag-and-drop: go to the ‘Images’ tab in the Project Management panel, set your mouse cursor on the row of an image stack and drag-and-drop it into one of the 2D viewports.

Example of the “2D by 2D” layout (showing two image stacks side-by-side in axial view):

![Example of the “2D by 2D” layout](image)

Note that you can always check which image stack is shown in which 2D viewport via the indicators (showing the name of the stack) on top of that viewport. Also, you can always check which stack is the active image stack via the blue rectangle (grey rectangles are for non-active stacks).

- **Overlaying the segmentation of one image stack on another stack:**
  When Mimics is a multi-stack layout, you can overlay the objects of one image stack on the other stacks shown in the layout. To do so, go to the ‘View’ menu and click ‘Overlay’.
  
  ![Overlay](image)

  You can do this with masks or STL contours, allowing you to visualize the segmentation created on one image stack on top of another image stack. (For instance in the case of metal artifact reduction, you can visualize the segmentation created on the filtered stack on top of the original images for the purpose of reviewing correctness).

- **Changing the active image stack:**
  Any operations you perform in Mimics (segmentations, image filters, etc) will generally only be applied to the ‘active’ stack. If you want to apply operations to another stack, you need to make this other stack active first. This can be done as follows:
When you are in a single-stack layout: Drag-and-drop an image stack from the ‘Images’ tab of the Project Management panel into one of the 2D viewports. You will see that this stack is now the active stack (blue rectangle).

When you are in multi-stack layout: If the stack that you want to make active is already displayed in one of the 2D viewports but is not active yet, then it will have a grey rectangle in the upper-left corner. Click on the grey rectangle to make this stack active. If the stack that you want to make active is not currently displayed in one of the 2D viewports, then make sure to display it first (by drag-and-dropping it into one of the viewports).

- **Linking objects to an image stack:**
  Each object (Parts, masks, etc.) is generally linked to a certain image stack, usually the image stack on which the object was created. The link is shown as a column in the tabs of the Project Management panel. You can re-assign an object to another stack by clicking on a field in this column, a drop-down menu will then appear where you can select the stack.
Appendix B – PACS integration – Advanced notes

A.1. Installation

Note that the “PACS integration” component is optional during installation: if you select “Custom” (instead of “Complete”) installation you can check off installation of this component in order to save disk space or avoid extra components.

A.2. Administration mode

A new section “PACS Administration” was added in File > Preferences. This allows to distinguish between a “user-managed mode” and an “administrator-managed mode”.

In the administrator-managed mode, the admin can share the PACS configuration over multiple users. Concretely, the admin can use File > Configure PACS to configure the PACS connection on the given workstation, and can then ‘share’ it so that all users on that workstation can use the same configuration (and don’t need to configure the connection themselves anymore).