Regulatory Information

The Mimics Innovation Suite software version 22.0 (released in 2019) consists of the components Materialise Mimics 22.0 and Materialise 3-matic 14.0.

Materialise Mimics 22.0 and Materialise 3-matic 14.0 are not medical devices. Any reference that is made to the design of medical devices within the Materialise Mimics 22.0 or Materialise 3-matic 14.0 user documentation (including user guides or tutorials) refers to a research context.

Usage of the software signifies your acceptance of the above.
Contents

Regulatory Information ............................................................................................................. 2
Contents......................................................................................................................................... 3
1 What’s New ................................................................................................................................. 4
  1.1. Base module - Segmentation improvements ....................................................................... 4
  1.2. Base module - Other improvements .................................................................................. 6
  1.3. Cardiovascular module – CT Heart .................................................................................... 7
  1.4. Scripting module ............................................................................................................... 8
  1.5. Analysis module ............................................................................................................... 9
2. Known issues .............................................................................................................................. 9
  2.1. Installation ....................................................................................................................... 9
  2.2. Base module - General .................................................................................................... 9
  2.3. Base module - Segmentation ........................................................................................... 10
  2.4. Base module – 4D and Multi stack functionality .............................................................. 11
  2.5. Other modules ................................................................................................................. 11
3. System Requirements ............................................................................................................... 12
  3.1. Minimum Requirements .................................................................................................. 12
  3.2. Recommended Requirements ......................................................................................... 12
4. Contact Information .................................................................................................................. 13
Appendix A - Change Log ............................................................................................................ 13
If you had an ALPHA or BETA release of Materialise Mimics 22.0 installed before, you need to first uninstall it before installing this release. Go to Control Panel → Programs and Features, find the ALPHA/BETA release (look for “Materialise Mimics …”) and double-click to uninstall. Only then install this release to avoid issues with the installation and use of this version.

Note that Mimics 22.0 is compatible with Mimics 14.0 and later. Compatibility with older Mimics releases is not supported anymore.

1 What’s New

Below is an overview of the main updates in this release, as compared to version 21.0. For minor updates, see Appendix A.

1.1. Base module - Segmentation improvements

1.1.1. Segment > Split Mask

With the Split Mask tool you can easily and quickly split a mask into multiple pieces corresponding to different anatomical parts, by making only a few markings. The Split Mask tool of previous releases only supports splitting a mask in two pieces at a time. This restriction has been removed. With the updated tool you can in a single operation split a mask into many parts (for instance for segmenting the spine, ankle or foot). This can substantially reduce the time of complex segmentation workflows.

The user interface of the tool was also improved.
By default, the tool dialog window shows two ‘regions’. You can start marking those regions in the 2D viewports. If you want to split into more than two parts, you can add extra regions by pressing the ‘+’ icon. You can also use the region list inside the tool dialog window to rename or delete regions, or switch back and forth between regions while marking on the 2D viewports. For more information, please see the user guide available in the software (Help > User Guide).

The Scripting Python API for Split Mask was extended accordingly (support more than two regions).

1.1.2. Advanced Segment > CT Bone Wizard

CT Bone Wizard offers a guided workflow for segmenting one or multiple bones from a CT scan. In previous releases, CT Bone Wizard was licensed as a separate Mimics module, but now it is offered as part of the Base module. It is available from the ‘Advanced Segment’ tab in Mimics.

The advantages of CT Bone Wizard compared to other segmentation tools in the Base module are that you can segment multiple bones at once (separate masks are created per bone) and that the tool guides the user through the process in a few steps, from selecting the bones of interest and setting the optimal threshold to finishing the resulting masks (closing gaps etc.). This reduces the learning curve for segmentation of bones.

For more information on how to use this tool, please see the user guide.

1.1.3. Segment > Multiple Slice Edit and 3D Interpolate

Multiple Slice Edit now also works on planar resliced views (cf View > Reslice Along Plane or View > Fluoroscopy). This allows you to work in a view where you can optimally see the anatomy of interest (for instance, along the relevant cardiac axes). The tool then interpolates in the direction orthogonal to that view. On resliced views, you can use the Ellipse, Rectangle and Lasso cursors but not the Flood Fill or Livewire cursors.

For Multiple Slice Edit as well as 3D Interpolate, the user interface and visualization were improved. In order to better inspect the original mask or the images, you can now temporarily hide all markings via the corresponding checkbox in the user interface. Furthermore, the new user interface incorporates extra measures and warnings to prevent loss of work in case of accidental mis-clicks.
1.1.4. **Visualization improvements**

The **3D Mask Preview** algorithm was updated. It is now faster than in previous versions. This speed-up applies to generating a first preview as well as to updating the preview after operations such as Edit Masks. As a reminder, note that you can trigger 3D Mask Preview by selecting a certain mask in the Masks Project Management tab and turning on the preview via the icon in the vertical toolbar of the 3D viewport:

The brush cursors used in various tools have been updated (this includes the tools **Edit Masks**, **Multiple Slice Edit**, **3D Interpolate**, **Split Mask** and **Smart Fill**). Furthermore, the Ellipse and Rectangle cursors now show the centerpoint of the cursor.

This can be particularly helpful when using the tools in Threshold mode, as you can check the exact pixel underneath your cursor, and check the gray value of the pixel in the Mimics status bar (bottom right corner of the Mimics interface).

1.2. **Base module - Other improvements**

1.2.1. **Spline-based features**

A number of Mimics features are spline-based:

- **Analyze > Create Spline** (only available with the Analysis module)
- **Segment > Trace Thin Structure**
- **Measure > Area Measurement**
- **View > Along Curve > Panoramic**

For all these features, a number of usability improvements were made, including:

- **Easier spline creation**: During spline creation, you can now press Escape to create the spline (instead of Escape causing the entire spline to be deleted as in Mimics 21.0).
- **Faster to add points**: For an already created (and selected) spline, you can now quickly add extra points in between existing points by hovering over the spline and clicking to place the extra point (instead of having to use the Spline toolbar as in Mimics 21.0).
- **Faster to delete points**: You can now quickly delete a point of a selected spline by hovering over the point to select it and pressing the Delete key (instead of having to use the Spline toolbar as in Mimics 21.0).

The algorithm that Mimics uses for spline interpolation was also updated. When creating a new spline in Mimics 22.0, the new algorithm will be used. When opening in Mimics 22.0 a project that was created in a previous version, the splines will be as before (old interpolation algorithm), however when the user edits the spline, the spline will be recalculated using the new algorithm.
1.2.2. Autosave

The performance of autosaving was improved. Please note that you can set the autosave frequency and autosave folder via File > Preferences (‘General’ section of Preferences).

1.2.3. Other improvements

Other improvements to the Base module include:

- Extra keyboard shortcuts were added. An overview of keyboard shortcuts can be found in the user guide, section General Information > Shortcuts.
- Some pop-up dialog boxes when opening a project from the Medical edition in the non-medical edition and vice versa were removed. The Log panel still shows which edition the project originates from.
- Collection of usage data was added to improve the user experience with the software. Data collection can be turned off via File > Preferences (‘Log’ section of Preferences).

1.3. Cardiovascular module – CT Heart

1.3.1. Advanced Segment > CT Heart

The CT Heart tool received a major update compared to version 21.0. The algorithm as well the user interface were redesigned. The new CT Heart tool allows fully automatic heart segmentation and better supports segmentation of the right side of the heart.

The new tool has two modes: automatic mode and semi-automatic mode. In both modes, the user can choose between segmenting only the left side of the heart or the full heart (left+right). Note that due to the design of the underlying algorithm, it is not possible to segment only the right side of the heart.

- In the automatic mode, the user can optionally adapt the bounding box on the 2D viewports and immediately start the calculation.

- The semi-automatic mode (called ‘Manual’ in the user interface) can be used when the output of the automatic mode is not satisfactory on a given case. This mode is similar to the CT Heart tool of previous versions: the user can adapt the bounding box, fine-tune the thresholds and place seedpoints to indicate the various structures to be segmented. The main novelty in the new version is the possibility to set thresholds separately for the left side and right side of the heart. For scans with uneven contrast, this allows to achieve better results compared to the previous version of CT Heart, where one threshold was used for both the left and right side of the heart. To use this option, select ‘Separate Thresholds’.
CT Heart: Semi-automatic mode, with ‘Separate Thresholds’.

Alternatively, it is also possible to use the same algorithm as was available in the previous versions, which uses the same threshold on the left as on the right side of the heart. This option is called ‘Single Threshold’. (This is recommend for instance for congenital heart cases.)

1.3.2. Scripting module

The Python APIs for heart segmentation were extended with the above-mentioned options. Note that the Python APIs for fully automatic heart segmentation are available in a separate module (not the standard Cardiovascular module).

1.4. Scripting module

A number of configuration updates were done for the Scripting module:

- Previous Mimics versions worked with Python 3.5. Mimics 22.0 works with Python 3.7.
- For previous versions, installation of Mimics included automatic installation of Python. This is not always convenient for users who already have Python installed. Hence, Mimics 22.0 installation no longer includes installation of Python. Instead, the user can configure Mimics to an already installed Python 3.7 version. Installation and configuration instructions are included in the Scripting guide (Help > Scripting Guide).

The Python API was extended. A full change log compared to the Mimics 21.0 API is included in the Scripting Guide.
1.5. Analysis module

The following changes apply to the Analysis module:

- **Analyze > Create Primitives**: Extra methods for creating analytical primitives were added.
- **Project Management tabs**: Surface objects, as could be calculated via Analyze > Freeform Surface until Mimics 20.0, are no longer supported or displayed in the Project Management tab.

2. Known issues

Note that Mimics 22.0 is compatible with Mimics 14.0 and later. Compatibility with releases older than Mimics 14.0 is not supported anymore.

2.1. Installation

- If you had an ALPHA or BETA release of Mimics 22.0 installed before, you need to first uninstall it before installing this final version. When not doing this, several issues can occur.
- When installing 3-matic using the MIS installer and then trying to install 3-matic via the ‘standalone’ 3-matic installer, or vice versa, issues can occur. Always uninstall one version before installing another version.
- Installation on Windows 2012 R2: Depending on the setup, it might be needed to first install the Microsoft Visual Studio 2015 redistributable before installing Mimics. (Issue 677507)
- When launching Mimics for the first time after installation, the licensing wizard will be shown. At this moment, you need to be connected to the internet, otherwise a crash can occur. (Issue 705420)

2.2. Base module - General

- If you possess a local license and also have a floating license server registered in Mimics, and you are not actually connected to this floating license server (for instance because you are in a domain where you don't have access to this sever), then Mimics might start to lag significantly. It is recommended to unregister this floating license server in Mimics in such situations (via Help > License > Floating License Server). This issue can also occur when having two different floating license servers registered in Mimics and not being connected to one of the two. (Issue 718375)
- Some features of Mimics do not work optimally on virtual machines with a CPU with only one logical core. As specified in the Minimum System Requirements, Mimics requires at least two cores. (Issue 673888)
- As Mimics writes certain temporary files to the system drive (often this is the C drive), Mimics can be unstable if there is insufficient space on that drive. (Issue 702750)
- File > Anonymize: Anonymization is not possible on projects or image series that do not contain DICOM tags (such as projects created with import of ‘raw’ images). Note that certain operations also remove the DICOM tags (such as Image > Crop Images and Image > Reslice Images). For this reason, it is recommended to anonymize the project (if desired) before applying such operations, for instance by anonymizing the project immediately after import of the images.
• File > Preferences: After turning on the setting 'Always ask to reduce images when loading' (in the 'General' section of Preferences), opening an existing project with existing objects (such as masks) will cause these objects to be deleted from the project. (Issue 569019)

• When performing workflows or running scripts that produce a lot of output to the log panel, Mimics can eventually start to lag. Clearing the log panel restores the normal performance. (Issue 605016)

• File > New Project: When importing images without a default orientation, the Change Orientation dialog is shown. Always apply the orientation and exit the Change Orientation dialog before saving the project. The same holds for cases with Gantry tilt: always apply the Gantry tilt correction and exit the Gantry Tilt dialog before saving. Failure to do so can lead to various issues. (Issue 516262)

• File > New Project: For ultrasound data, the image preview pane sometimes shows a bogus black/white image for the first images in the stack. This happens when the contrast on those images is very low. Scrolling through the stack in the preview pane will solve the problem (proper images will be shown). (Issue 478407)

• Visualization issues can occur on high resolution monitors. (Issue 545901, 546080)

• File > Import Project: When applying 'Import project' to import a project containing X-ray objects, the X-ray objects are imported as separate image sets in the 'Images' Project Management tab, while they not should not appear in the 'Images' tab. (Issue 595103)

• If you experience problems with the layout of Mimics, please use View > Layouts > Reset. (Issue 595898)

• File > Preferences: Pixel Unit preferences (Hounsfield or Grayvalues) are not remembered between Mimics sessions. (Issue 503774)

• When using open GL rendering and drawing 'Thin structures' or Splines in the 3D viewport, some visual artifacts might occur. You can switch to another rendering method via File > Preferences > 3D Settings. (Issue 604078)

• Image > Alignment Image: When performing 'File > Save As' on a project with alignment images ('scouts') the alignment images will be deleted from the project when saving with the option "Mimics Project Files". As workaround, use the option "Mimics 18.0 - 20.0 project files". (Issue 716020)

2.3. Base module - Segmentation

• Segment > Calculate mask from Object: If the object spans the entire image stack including the top-most and bottom-most slice, the calculated mask in the top-most and bottom-most slice might not be optimal. Care needs to be taken to visually check the content of the mask in these slices. (Issue 523043)

• Segment > Calculate mask from Object: The thresholds set for the calculated mask might not be optimal and might need to be manually adapted. (Issue 584976)

• Segment > Thresholding: On projects with Gantry tilt, the crop box of the Thresholding tool by default does not cover the entire image stack (it does not cover the topmost slice). (Issue 440799)

• Segment > 3D LiveWire: Contour points cannot be removed with the Del key. Instead, remove points by clicking with the right mouse button. (Issue 600484)
- Segment > Edit Masks: When working in Threshold mode on large datasets with the preview inside the cursor turned on, performance might be lower. Turn off the preview inside the cursor for better performance. (Issue 592834)

- Segment > 3D Interpolate: 'Redo' (after 'Undo') does not work for marking operations if Auto-interpolate is on. (Issue 602966)

2.4. Base module – 4D and Multi stack functionality

- If the name of an image series is blank (displayed as 'n/a' in the 'Images' Project Management tab), it is recommended to manually assign an appropriate name (via clicking on the image series in the 'Images' tab) to avoid confusion between different image series.

- File > New Project: When importing multiple image series of which several series have the 'same table position', the warning for 'same table position' is only shown for the first such image series. (Issue 535869)

- File > Save As: When using 'Save As' to older Mimics format, certain objects are not saved, in particular objects that are assigned to the active image series but have a link to an object from a non-active image series. (Issue 565700)

- File > Save As: When using the option 'Save images compressed as Jpeg' only the active image series is saved compressed as Jpeg (other image series are saved in the default way). (Issue 565417)

- File > Save Screenshot: Unexpected behaviour can occur when saving screenshots in certain multi-stack layouts. It is advised to check the content of the screenshots. (Issue 599977)

- File > Preferences: For multi-stack projects containing CT images as well as MRI images, the Pixel unit (Hounsfield or Grayvalues) in Preferences does not change automatically to Grayvalues after activating the MRI image set. (Issue 598540)

2.5. Other modules

- Analyze > Create Primitives: When fitting primitives to a Part or marked surfaces of a Part, the fitting might be influenced by the triangulation of the Part. It is advised to always visually check for a proper fit. (Issue 594335)

- Analyze > Create Primitives: When fitting primitives to marked surfaces of a Part, rendering issues might occur when using the OpenGL renderer. You can specify another renderer via File > Preferences > 3D Settings. (Issue 548075)

- Analyze: It is advised to never copy-paste analytical primitives between projects with different units (millimeter projects, micrometer projects, nanometer projects). (Issue 585579, 585587)

- Analyze > Centerline: When copy-pasting a centerline from Mimics to 3-matic and back to Mimics, and extra obsolete STL will be created in the 'Objects' tab in Mimics. (Issue 712404)

- Analyze > Measure and Analyze (Simulation module): When creating a new template, please do not create planes with the name "Sagittal plane". This name is reserved in Mimics for an automatically calculated plane (for instance, when entering the Simulation layout via View > Layouts > Simulation). (Issue 696460)

- Analyze > Measure and Analyze (Simulation module): When opening in Mimics 22 projects created in earlier versions of Mimics, points might get attached to another part
(this is due to an update in the logic for attaching points to parts in Mimics 22). When opening such projects in Mimics 22, please review the results.

- **Align > Reposition (Simulation module):** When using 'Restrict DOF' (with the 'Translate Along Axis' option), the selected Part will become unselected, making the controls of the Reposition tool look disabled. As a workaround, select the Part again and reopen the tool. (Issue 716412)

- **Centerline measurements:** If a centerline is set invisible but some of its corresponding centerline measurements are set visible, then hovering with the mouse cursor over these measurements in the 3D viewport can make the cursor shape change. To get back to the default cursor shape, press ESC and move the mouse. (Issue 716446)

- **Advanced Segment > CT Heart:** Results of CT Heart are influenced by the setting 'Compress images in memory' in File > Preferences > General. Results are often better when compress images is turned off. (Issue 413082)

- **Advanced Segment > Pulmonary:** Fissure objects are not automatically linked to the active image stack (Issue 585241)

- **FEA > Create Voxel Mesh:** No progress is being shown during calculation. It is advised to not interrupt Mimics during calculation. (Issue 602805)

- **Scripting:** When running scripts with the log panel turned off, the user will not be able to see any errors or log output produced by the script. Hence, for scripting users, it is recommend to always have the log panel on (View > Log panel). (Issue 480881)

### 3. System Requirements

#### 3.1. Minimum Requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows® 7 SP1 (including KB2533623 and KB2999226) – 64bit</td>
<td>Intel® Core™ 2 Duo / AMD Athlon™ X2 AM2 or equivalent</td>
</tr>
<tr>
<td>Internet Explorer® 10</td>
<td>4 GB RAM</td>
</tr>
<tr>
<td>PDF viewer</td>
<td>DirectX® 11.0 compliant graphics card with 1 GB RAM</td>
</tr>
<tr>
<td>.NET framework 4.5.2 (or higher)</td>
<td>5 GB free hard disk space</td>
</tr>
<tr>
<td></td>
<td>Resolution of 1280x1024</td>
</tr>
</tbody>
</table>

Note: Mac® users can install MIS using Boot Camp® in combination with a supported Windows OS

#### 3.2. Recommended Requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows® 10 version 1803– 64bit</td>
<td>Third generation Intel® Core™ i5/i7 or equivalent</td>
</tr>
<tr>
<td>Internet Explorer® 10</td>
<td>16 GB RAM</td>
</tr>
<tr>
<td>PDF Viewer</td>
<td>DirectX® 11.0 compliant AMD Radeon™ / NVIDIA® GeForce® card with 2 GB RAM</td>
</tr>
<tr>
<td>.NET framework 4.5.2 (or higher)</td>
<td>20 GB free hard disk space</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td></td>
<td>Resolution of 1680x1050 or higher</td>
</tr>
</tbody>
</table>

Note: Other qualifications may apply. When working with datasets larger than 1GB the system should comply with the recommended system requirements. Advanced segmentation tools such as Smart Expand and Coronary segmentation require hardware as specified in the recommended requirements even for smaller datasets. When working with 4D or multi stack data, the amount of RAM needed increases as you import more image series into the project.

It is recommended to use our software within a hardware and/or network environment in which cyber security controls have been implemented including anti-virus and use of firewall.

The following operating systems were used to test Materialise Mimics 22.0:

- Windows 7 Professional 64-bit (with SP1)
- Windows 10 Pro 64-bit

Materialise Mimics is software and does not degrade in performance. Its lifetime is determined by commercial requirements, obsolescence of its techniques or obsolescence caused by changes in its host environment (refer to above requirements). Support can in any case not be guaranteed beyond 7 years after the release of this particular version of the software.

4. Contact Information

For technical support, please contact our Customer Support team: mimics@materialise.be.


For scripting related support, the MIS Scripting Forum can be consulted: https://community.materialise.com/.

Appendix A - Change Log

Section 1 already gave an overview of the highlights of this release. Below is a more schematic overview of changes.

**Base module:**

- New Intended Use
- Segment > Split Mask: New User Interface (UI), added support for splitting in multiple regions
- Segment > Multiple Slice Edit: New UI, added support for planar resliced views, improved visualization
- Segment > 3D Interpolate: New UI, improved visualization
- Advanced Segment > CT Bone Wizard: Made available in Mimics Base module (and renamed)
• 3D Mask Preview: New and faster preview algorithm
• Brush-based features (Segment > Edit Masks, Multiple Slice Edit, 3D Interpolate, Split Mask, Smart Fill): New brush cursors, including visualization of center of the cursor
• Spline-based features (Analyze > Create Spline, Segment > Trace Thin Structure, Measure > Area Measurement, View > Along Curve > Panoramic):
  o Usability improvements
  o New interpolation algorithm
• Measure > Area Measurement: Minor extension of the calculated measurements
• Autosave: Performance improvements
• Shortcuts: Added extra keyboard shortcuts
• File > Preferences: Added new preference settings related to Autosave ('General' section of Preferences) and Usage data collection ('Log' section of Preferences)
• Project Management tabs: Part properties: 'Edit' button for 'Type' removed from properties page (can be launched via File > Preferences instead)
• Upgraded to License Server 7.0
• Help menu restructured
• Updated colors of Status Bar

**Scripting module:**

• Configuration:
  o Upgraded from Python 3.5.2 to Python 3.7
  o Removed automatic Python installation as part of Mimics installation
• Python API:
  o Added extra API (see ‘API Change Log’ in Scripting Guide)
  o Added new submodule containing Python API for automatic heart segmentation

**Analysis module:**

• Analyze > Create Primitives: Added extra creation methods for analytical primitives
• Analyze > Fit Centerline: Minor changes in fitting algorithm
• Surfaces: Removed support for surfaces (surfaces created via Analyze > Freeform Surface in previous Mimics versions are no longer displayed in the Project Management tab)

**Simulation module:**

• Analyze > Measure and Analyze: Improved logic of attachment of points to parts (Mimics now remembers for each point to which part it is attached).

**Cardiovascular (C&V) module:**

• CT Heart: Updated tool and algorithm